re = /https?:\/\/\S*/m
str = 'some text before http://some_domain.com/some_link some text before https://www.some_domain.com/some_link some text after'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end