$re = '/https?:\/\/\S*/m';
$str = 'some text before http://some_domain.com/some_link some text before https://www.some_domain.com/some_link some text after';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);