import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(?:[%]{2})*[%])[%][sidfoOc]";
final String string = "# Basic - Expandable object format string\n"
+ "Format string object: %o\n\n"
+ "# Basic - Single string format string\n"
+ "Format string string: %s\n\n"
+ "# Basic - Single integer format string\n"
+ "Format string integer: %i\n\n"
+ "# Basic - Single integer format string\n"
+ "Format string integer: %d\n\n"
+ "# Advanced - Message with expandable object, string, and integer format strings\n"
+ "Raw value: %o\\nTo string: %s\\nAs number: %i\n\n"
+ "# Advanced - Formatted message with styled heading, and body with value, escaped percentage\n"
+ "%c[Header]%c msg about %i values (%o)\n\n"
+ "%c[Header]%c msg about %i objects, %i%% total%c\\n Object array: %o";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}