import re
regex = re.compile(r"(?<!(?:[%]{2})*[%])[%][sidfoOc]", flags=re.MULTILINE)
test_str = ("# Basic - Expandable object format string\n"
"Format string object: %o\n\n"
"# Basic - Single string format string\n"
"Format string string: %s\n\n"
"# Basic - Single integer format string\n"
"Format string integer: %i\n\n"
"# Basic - Single integer format string\n"
"Format string integer: %d\n\n"
"# Advanced - Message with expandable object, string, and integer format strings\n"
"Raw value: %o\\nTo string: %s\\nAs number: %i\n\n"
"# Advanced - Formatted message with styled heading, and body with value, escaped percentage\n"
"%c[Header]%c msg about %i values (%o)\n\n"
"%c[Header]%c msg about %i objects, %i%% total%c\\n Object array: %o")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")