const regex = /(?<!(?:[%]{2})*[%])[%][sidfoOc]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(?:[%]{2})*[%])[%][sidfoOc]', 'gm')
const str = `# Basic - Expandable object format string
Format string object: %o
# Basic - Single string format string
Format string string: %s
# Basic - Single integer format string
Format string integer: %i
# Basic - Single integer format string
Format string integer: %d
# Advanced - Message with expandable object, string, and integer format strings
Raw value: %o\\nTo string: %s\\nAs number: %i
# Advanced - Formatted message with styled heading, and body with value, escaped percentage
%c[Header]%c msg about %i values (%o)
%c[Header]%c msg about %i objects, %i%% total%c\\n Object array: %o`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}