use strict;
my $str = '<iframe width="420" height="315" src="https://www.youtube.com/embed/S6psuUt8caM" frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src=\'https://www.youtube.com/embed/S6psuUt8caM\' frameborder="0" allowfullscreen></iframe>
<iframe width="420" height="315" src=https://www.youtube.com/embed/S6psuUt8caM frameborder="0" allowfullscreen></iframe>
<iframe src="http://livestream.com/accounts/2600567/events/3949236/videos/85086024/player?autoPlay=false&height=360&mute=false&width=640" width="640" height="360" frameborder="0" scrolling="no"></iframe>
<iframe src="https://player.vimeo.com/video/130848521?color=ffffff&badge=0" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href="https://vimeo.com/130848521">samuel-613</a> from <a href="https://vimeo.com/billylumby">Billy Lumby</a> on <a href="https://vimeo.com">Vimeo</a>.</p>';
my $regex = qr/src=["|']?((?:https?:\/\/)?(?:www\.)?([^\/]+)([^\?|^"|^'|^\s]*))/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}