# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"src=[\"|']?((?:https?:\/\/)?(?:www\.)?([^\/]+)([^\?|^\"|^'|^\s]*))"
test_str = ("<iframe width=\"420\" height=\"315\" src=\"https://www.youtube.com/embed/S6psuUt8caM\" frameborder=\"0\" allowfullscreen></iframe>\n"
"<iframe width=\"420\" height=\"315\" src='https://www.youtube.com/embed/S6psuUt8caM' frameborder=\"0\" allowfullscreen></iframe>\n"
"<iframe width=\"420\" height=\"315\" src=https://www.youtube.com/embed/S6psuUt8caM frameborder=\"0\" allowfullscreen></iframe>\n"
"<iframe src=\"http://livestream.com/accounts/2600567/events/3949236/videos/85086024/player?autoPlay=false&height=360&mute=false&width=640\" width=\"640\" height=\"360\" frameborder=\"0\" scrolling=\"no\"></iframe>\n"
"<iframe src=\"https://player.vimeo.com/video/130848521?color=ffffff&badge=0\" width=\"500\" height=\"281\" frameborder=\"0\" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe> <p><a href=\"https://vimeo.com/130848521\">samuel-613</a> from <a href=\"https://vimeo.com/billylumby\">Billy Lumby</a> on <a href=\"https://vimeo.com\">Vimeo</a>.</p>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.