const regex = /\*\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*\\s*(([^\\n]*(\\n|$))*?)(?=\\n|#|<[uo]l>|\\*|$)', 'g')
const str = `* bullet
text on new line
more text
this should be a separate block
* bullet
text on a new line
more text
this should be a separate block`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}