$re = '/\*\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)/';
$str = '* bullet
text on new line
more text
this should be a separate block
* bullet
text on a new line
more text
this should be a separate block';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);