import re
regex = re.compile(r"\*\s*(([^\n]*(\n|$))*?)(?=\n|#|<[uo]l>|\*|$)")
test_str = ("* bullet\n"
"text on new line\n"
"more text\n\n"
"this should be a separate block\n\n\n"
"* bullet\n"
"text on a new line\n"
"more text\n\n"
"this should be a separate block")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")