#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b[\w =]*"
Local $sString = "[[[tab name=dog content=cat]]]" & @CRLF & _
"[[[tab name=dog content=cat|tab name=dog2 content=cat2]]]" & @CRLF & _
"[[[tab name=dog content=cat|tab name=dog2 content=cat2|tab name=dog3 content=cat3]]]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")