$re = '/\b[\w =]*/';
$str = '[[[tab name=dog content=cat]]]
[[[tab name=dog content=cat|tab name=dog2 content=cat2]]]
[[[tab name=dog content=cat|tab name=dog2 content=cat2|tab name=dog3 content=cat3]]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);