re = /\b[\w =]*/
str = '[[[tab name=dog content=cat]]]
[[[tab name=dog content=cat|tab name=dog2 content=cat2]]]
[[[tab name=dog content=cat|tab name=dog2 content=cat2|tab name=dog3 content=cat3]]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end