#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=;)\s+\/\/[^\n]+"
Local $sString = "function session(){" & @CRLF & _
" return 1; // this default value for session" & @CRLF & _
" just more code" & @CRLF & _
" again, more code with a comment; // this is another comment" & @CRLF & _
" a = "let's try // to check this one, no match!";" & @CRLF & _
" return false;" & @CRLF & _
" " & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")