$re = '/(?<=;)\s+\/\/[^\n]+/m';
$str = 'function session(){
return 1; // this default value for session
just more code
again, more code with a comment; // this is another comment
a = "let\'s try // to check this one, no match!";
return false;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);