const regex = /(?<=;)\s+\/\/[^\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=;)\\s+\\\/\\\/[^\\n]+', 'gm')
const str = `function session(){
return 1; // this default value for session
just more code
again, more code with a comment; // this is another comment
a = "let's try // to check this one, no match!";
return false;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}