import Foundation
let pattern = #"(?:(?:dictad|pronunciad)(?:a|o)) por (?:don |doña )?([\w\s]+), juez(?:a?) (?:suplente)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por ARMANDO FREDY PUELLES ROJAS, Juez del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
V-1560-2018 Foja: 1 Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por doña SANDRA JANETT ORELLANA ARAYA, Jueza Suplente del Primer Juzgado de Letras de Vallenar',
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)