$re = '/(?=([A-Z]\d{2,4}(?:[A-Z](?!\d{2,4}))?))/i';
$str = 'F328AG560F33
F328AG560F3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);