re = /(?=([A-Z]\d{2,4}(?:[A-Z](?!\d{2,4}))?))/i
str = 'F328AG560F33
F328AG560F3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end