using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+[.,]\d+(?:\.\d+)?\p{Zs}+SAR\b";
string input = @"45.29 SAR
4,523.88 SAR";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}