$re = '/\b\d+[.,]\d+(?:\.\d+)?\p{Zs}+SAR\b/';
$str = '45.29 SAR
4,523.88 SAR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);