package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+[.,]\d+(?:\.\d+)?\p{Zs}+SAR\b`)
var str = `45.29 SAR
4,523.88 SAR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}