#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!\d{5}\b)\d+\b(?:\s*\w\b)?(?=\D*\b\d{5}\b|\D*$)"
Local $sString = " 32 Rue Jean Jaures 69000 Lyon" & @CRLF & _
" Bâtiment 1 32 Rue Jean Jaures 69000 Lyon" & @CRLF & _
" 32 B Jean Jaures 69000 Lyon" & @CRLF & _
" Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")