import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\d{5}\\b)\\d+\\b(?:\\s*\\w\\b)?(?=\\D*\\b\\d{5}\\b|\\D*$)";
final String string = " 32 Rue Jean Jaures 69000 Lyon\n"
+ " Bâtiment 1 32 Rue Jean Jaures 69000 Lyon\n"
+ " 32 B Jean Jaures 69000 Lyon\n"
+ " Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}