using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\d{5}\b)\d+\b(?:\s*\w\b)?(?=\D*\b\d{5}\b|\D*$)";
string input = @" 32 Rue Jean Jaures 69000 Lyon
Bâtiment 1 32 Rue Jean Jaures 69000 Lyon
32 B Jean Jaures 69000 Lyon
Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}