import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\bConnected\\s+server\\s+via\\s+proxy\\s+\\[\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}:[\\d-]+\\].*$";
final String string = "ahsdsgda ashgj dhgasjdg jsd Connected server via proxy [10.20.60.60:808-3] ashdask dh\n\n"
+ "ahsdsgda ashgj dhgasjdg jsd Connected server proxy [10.20.60.60:808-3] ashdask dh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}