# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?\bConnected\s+server\s+via\s+proxy\s+\[\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}:[\d-]+\].*$"
test_str = ("ahsdsgda ashgj dhgasjdg jsd Connected server via proxy [10.20.60.60:808-3] ashdask dh\n\n"
"ahsdsgda ashgj dhgasjdg jsd Connected server proxy [10.20.60.60:808-3] ashdask dh")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.