const regex = new RegExp('^.*?\\bConnected\\s+server\\s+via\\s+proxy\\s+\\[\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}:[\\d-]+\\].*$', 'gm')
const str = `ahsdsgda ashgj dhgasjdg jsd Connected server via proxy [10.20.60.60:808-3] ashdask dh
ahsdsgda ashgj dhgasjdg jsd Connected server proxy [10.20.60.60:808-3] ashdask dh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}