#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1(?:[01]\d{2}|200)(?::1(?:[01]\d{2}|200)(?!:)|,1(?:[01]\d{2}|200))*$"
Local $sString = "1000" & @CRLF & _
"1200" & @CRLF & _
"1000:1200" & @CRLF & _
"1000,1200" & @CRLF & _
"1010:1015,1019,1025:1027" & @CRLF & _
"1000,1200,1100" & @CRLF & _
"1000:1001:1002" & @CRLF & _
"1000,1200,1100," & @CRLF & _
"1201" & @CRLF & _
"999" & @CRLF & _
",1111" & @CRLF & _
":1111" & @CRLF & _
":1111," & @CRLF & _
",1111:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")