const regex = /^1(?:[01]\d{2}|200)(?::1(?:[01]\d{2}|200)(?!:)|,1(?:[01]\d{2}|200))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^1(?:[01]\\d{2}|200)(?::1(?:[01]\\d{2}|200)(?!:)|,1(?:[01]\\d{2}|200))*$', 'gm')
const str = `1000
1200
1000:1200
1000,1200
1010:1015,1019,1025:1027
1000,1200,1100
1000:1001:1002
1000,1200,1100,
1201
999
,1111
:1111
:1111,
,1111:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}