import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1(?:[01]\\d{2}|200)(?::1(?:[01]\\d{2}|200)(?!:)|,1(?:[01]\\d{2}|200))*$";
final String string = "1000\n"
+ "1200\n"
+ "1000:1200\n"
+ "1000,1200\n"
+ "1010:1015,1019,1025:1027\n"
+ "1000,1200,1100\n"
+ "1000:1001:1002\n"
+ "1000,1200,1100,\n"
+ "1201\n"
+ "999\n"
+ ",1111\n"
+ ":1111\n"
+ ":1111,\n"
+ ",1111:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}