#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zF-ZC])[0-9]{4}"
Local $sString = "C4565" & @CRLF & _
"Y4565" & @CRLF & _
"a4565" & @CRLF & _
"f4565" & @CRLF & _
"" & @CRLF & _
"a456a" & @CRLF & _
"A4565"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")