const regex = /([a-zF-ZC])[0-9]{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zF-ZC])[0-9]{4}', 'gm')
const str = `C4565
Y4565
a4565
f4565
a456a
A4565`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}