$re = '/([a-zF-ZC])[0-9]{4}/m';
$str = 'C4565
Y4565
a4565
f4565
a456a
A4565';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);