$re = '/\S+:\S*/';
$str = 'tag:value something alone: and other:tag :value
try /\\S*:\\S*/g and see the difference!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);