re = /\S+:\S*/
str = 'tag:value something alone: and other:tag :value
try /\\S*:\\S*/g and see the difference!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end