package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b`)
var str = `autodiscover.microsoft.com. 3600 IN A 131.107.125.5
microsoft.com. 3600 IN TXT "v=spf1 include:_spf-a.microsoft.com include:_spf-b.microsoft.com include:_spf-c.microsoft.com -all"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}