re = /\b/m
str = 'autodiscover.microsoft.com. 3600 IN A 131.107.125.5
microsoft.com. 3600 IN TXT "v=spf1 include:_spf-a.microsoft.com include:_spf-b.microsoft.com include:_spf-c.microsoft.com -all"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end