import re
regex = re.compile(r"\b", flags=re.MULTILINE)
test_str = ("autodiscover.microsoft.com. 3600 IN A 131.107.125.5\n"
"microsoft.com. 3600 IN TXT \"v=spf1 include:_spf-a.microsoft.com include:_spf-b.microsoft.com include:_spf-c.microsoft.com -all\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")