using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""\\]*(\\.[^""\\]*)*)""";
string input = @"jack betty ""donald jake rita"" lorie katie danny, ""donald and brad and katie""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}