re = /"([^"\\]*(\\.[^"\\]*)*)"/
str = 'jack betty "donald jake rita" lorie katie danny, "donald and brad and katie"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end