$re = '/"([^"\\\\]*(\\\\.[^"\\\\]*)*)"/';
$str = 'jack betty "donald jake rita" lorie katie danny, "donald and brad and katie"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);