package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*)\s(\w*)`)
var str = `This is a test`
var substitution = "\L$1_$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}