const regex = /(\w*)\s(\w*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w*)\\s(\\w*)', 'gm')
const str = `This is a test`;
const subst = `\L$1_$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);