use strict;
my $str = 'This is a test';
my $regex = qr/(\w*)\s(\w*)/mp;
my $subst = '\\L$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";