using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\s)ThisPass\+(?=\s|$)";
string input = @"Test for ThisPass++ Test for ThisPass ThisPass+ ThisPass, ThisPass; ThisPass.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}