$re = '/(?:^|\s)ThisPass\+(?=\s|$)/';
$str = 'Test for ThisPass++ Test for ThisPass ThisPass+ ThisPass, ThisPass; ThisPass.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);