const regex = /^(?!.*love).*fruit/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*love).*fruit', 'gm')
const str = `We all love green fruit.
-> dont match
We all love to walk.
-> dont match
We all green fruit.
-> match
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}