re = /^(?!.*love).*fruit/m
str = 'We all love green fruit.
-> dont match
We all love to walk.
-> dont match
We all green fruit.
-> match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end