const regex = /^(?=(?:(?!\bno\b).)*\byes\b).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:(?!\\bno\\b).)*\\byes\\b).*', 'gm')
const str = `Hello world, major yes here!
Hell no yes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}